Обмен между 7.7 и 8.3 с помощью КД

  1. 5 нед. назад

    Всем привет!
    кто юзал такой обмен? какие особенности есть?

    обмен нужен пользователям, чтобы выгружать и загружать данные вручную

    вот тока я не помню, а как кад запусать в 7.7 там же нету формы вроде? или есть?

  2. ‹ Ранее
  3. 2 нед. назад

    придумал гениальную штуку

    Ðîäèòåëü = ÂûáÇàÿâêà.Òìö.Ðîäèòåëü;

    Ïîêà Ñ÷åò <> 1 Öèêë

    Ðîäèòåëü = Ðîäèòåëü.Ðîäèòåëü;
    Ñ÷åò = Ðîäèòåëü.Óðîâåíü();
    Ñîîáùèòü("Ñ÷åò = "+Ñ÷åò);
    ÊîíåöÖèêëà;

    Ñîîáùèòü("Ðîäèòåëü âåðõíåãî óðîâíÿ = "+ Ðîäèòåëü);

  4. все , я спать

  5. 05.04.2021 21:41:43 отредактировано itdev

    NewTesla Как отменить загрузку документа в КД, если мы не нашли какой-то реквизит в приемнике (т.е настроили соотвесттвие и Спр.Склад =>Спр.Контрагенты

    Может, передать значение в параметр и в обработчике перед или при загрузке проверять.

    Ответы: (103)
  6. itdev Может, передать значение в параметр и в обработчике перед или при загрузке проверять.

    я циклом попроовал вроде норм)

    Счет = ВыбЗаявка.Тмц.Уровень();
    Родитель = ВыбЗаявка.Тмц.Родитель;

    Пока Счет <> 1 Цикл
    Родитель =РОдитель.РОдитель;
    Счет = Родитель.Уровень();
    КонецЦикла;

    НужныйРодитель = Родитель;

  7. 1 нед. назад

    Вопрос к Браззам:

    есть у нас два документа одинаковых в источнике
    название : "Заявка Покупателя"

    один из документов = услуга

    в приемнике это должен быть один документ

    я сделал щас так

    1 пвд выгружае 1вый документ
    2 пвд выгружает второй и попараметрам поиска ище первый и заполняет тч "Услуги"

    ВНИМАНИЕ ВОПРОС :)

    юзер захотел одну услугу цепрять к нескольким документам

    як ето сделать? если известно, що попараметрам поиска он ищет только первый окумент вроде и берет его за основу?

  8. а, придумал!

    если хоть один найден, потом делаем запрос и делаем загрузку дкументов в модуле "после загрузки"

    ура!!!!!!!!!! ееееееееееее

  9. Вот такой вопрос еще:

    есть крч необходимость выгружать строки неограниченной длины

    но иногда строка неограниченной длины может быть пустой, поэтому я делаю проверку СокрЛП

    и проверяю на ""

    прикол в том , тчо при перед выгрузкой если ставлю проверку она работает и не выгружает

    а при выгрузке не работает наверное! и в значение параметров попадает хз что и обработка загрузки потом рушается что "конструктор не найден"

    кто сталкивался?

    СтрокаАдресКарта = СокрЛП(Источник.АдресКарта);

    Если СтрокаАдресКарта = "" Тогда
    СтрокаАдресКарта = "ПустаяСтрока";
    КонецЕсли;

    УзелПарам=СоздатьУзел("ЗначениеПараметра");
    УстановитьАтрибут(УзелПарам,"Имя","АдресКарта");
    ЗаписатьЭлемент(УзелПарам,"Значение",СтрокаАдресКарта);
    ДобавитьПодчиненный(Приемник,УзелПарам);

    Ответы: (107)
  10. 6 дн. назад

    NewTesla Вот такой вопрос еще:

    есть крч необходимость выгружать строки неограниченной длины

    но иногда строка неограниченной длины может быть пустой, поэтому я делаю проверку СокрЛП

    и проверяю на ""

    прикол в том , тчо при перед выгрузкой если ставлю проверку она работает и не выгружает

    а при выгрузке не работает наверное! и в значение параметров попадает хз что и обработка загрузки потом рушается что "конструктор не найден"

    кто сталкивался?

    СтрокаАдресКарта = СокрЛП(Источник.АдресКарта);

    Если СтрокаАдресКарта = "" Тогда
    СтрокаАдресКарта = "ПустаяСтрока";
    КонецЕсли;

    УзелПарам=СоздатьУзел("ЗначениеПараметра");
    УстановитьАтрибут(УзелПарам,"Имя","АдресКарта");
    ЗаписатьЭлемент(УзелПарам,"Значение",СтрокаАдресКарта);
    ДобавитьПодчиненный(Приемник,УзелПарам);

    Уроза рамадан начался. Теслыч ты держишь?

    Ответы: (108)
  11. Hans Уроза рамадан начался. Теслыч ты держишь?

    я держу свой член и ищу телочек)

    Ответы: (109)
  12. NewTesla я держу свой член и ищу телочек)

    Тебе надо рамадан соблюдать. Ты толстый [...]. У тебя давление уже 150 постоянно.

    Ответы: (110) (111)
  13. Hans Тебе надо рамадан соблюдать. Ты толстый [...]. У тебя давление уже 150 постоянно.

    по ТЛМС голодание раз в месяц

    а неделю голодать опасно и не продуктивно

  14. Hans Тебе надо рамадан соблюдать. Ты толстый [...]. У тебя давление уже 150 постоянно.

    я уразу в плане секса соблюдаю ща=тож норм

  15. 5 дн. назад

    вопрос по обработке выгрузке из 77, юзеры попросили сделать интерфейс попроще, я ща хочу слой добавить и при выборе. щоб параметры устанавливались, есть у кого готовый код?)

    или кто как делал?

    пользовательскийинтерфейсОбработка.jpg

  16. 14.04.2021 16:40:37 отредактировано NewTesla

    Браззы, вот еще вопрос = есть реквизит странный, который юзеры попросили заполнять программно при загрузке

    как я понял это реквизит формы " время разгрузки", а как лучше мне его заполняь тогда? ( в форме при открытии нежелательно юзать)

    hhhh.jpg

  17. т.е сама конфа у них обновляется)

    но если что как вариант можно создать отдельный реквизит и при открытии заполнять его)

    али как?

  18. Посмотри как заполняется при открытии. Если никак, то и из семёрки нечего тащить, ведь это не реквизит документа.

    Ответы: (116) (118)
  19. 14.04.2021 16:45:09 отредактировано NewTesla

    itdev Посмотри как заполняется при открытии. Если никак, то и из семёрки нечего тащить, ведь это не реквизит документа.

    не, его надо расчитывать , т.е мы берем этаж из семерки и расчитываем время разгрузки

    тока как его заполнять?

  20. 14.04.2021 16:47:24 отредактировано itdev

    Я грю, посмотри как он рассчитывается в коде восьмерки.
    Тогда будешь знать, что заполнять в конвертации

  21. itdev Посмотри как заполняется при открытии. Если никак, то и из семёрки нечего тащить, ведь это не реквизит документа.

    а на самой форме есть процедура, мы ее вызываем и она заполняет що то

    вопрос по времени разгрузки.jpg

  22. жмакаем на кнопку открывается форма для ввода времени

    в текущей форме

    &НаКлиенте
    Процедура ВвестиВремя(ПараметрыВводаВремени)
    	
    	ОткрытьФорму("ОбщаяФорма.упВводВремени", ПараметрыВводаВремени, ЭтаФорма,,ВариантОткрытияОкна.ОтдельноеОкно,,
    								  Новый ОписаниеОповещения("ОписаниеОповещенияОбратнаяОповестить",
    								  							ItobОбщегоНазначенияКлиент,
    															Новый Структура("Процедура", "УстановитьВремя")));
    	
    КонецПроцедуры
    

    * в форме ввода времени

    &НаСервере
    Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    	
    	Параметры.Свойство("ВидВремени", ВидВремени);
    	
    	ПараметрыВремя = '00010101';
    	Если Параметры.Свойство("Время", ПараметрыВремя) Тогда
    		Время = '00010101' + ПараметрыВремя;
    	КонецЕсли; 
    	
    	Если ВидВремени = "Погрузка" Тогда
    		ЭтаФорма.Заголовок = НСтр("ru='Введите время погрузки'");
    	ИначеЕсли ВидВремени = "Разгрузка" Тогда
    		ЭтаФорма.Заголовок = НСтр("ru='Введите время разгрузки'");
    	КонецЕсли;
    	
    КонецПроцедуры
    
    #КонецОбласти
    
    #Область ОбработчикиКомандФормы
    
    &НаКлиенте
    Процедура КомандаОК(Команда)
    	
    	Результат = Новый Структура;
    	Результат.Вставить("Время", 		Время);
    	Результат.Вставить("ВидВремени", 	ВидВремени);
    	
    	ЭтаФорма.Закрыть(Результат);
    	
    КонецПроцедуры
    
  23. 14.04.2021 16:51:40 отредактировано NewTesla

    почему в струкутуру не забросили, странно конечно

    пока идея такая = при открытии смотреть , если время на форме не заполнено, то брать из реквизита структуры (создать доп реквизит)

  24. 4 дн. назад

    Браззы, кто делал слои в семерке?)

    как переименовать наименование закладок?

    ВопросПоСлоям77.jpg

  25. 3 дн. назад

    а ктонить знает какой объем можно выгружать типовой выгрузкой из 77?

    а о я поставил большеой период и чето он подвис у меня

  26. 16.04.2021 17:47:36 отредактировано itdev

    Большой. Ты комментирование выгрузки поставил?

    Ответы: (124) (125)
  27. itdev Большой. Ты комментирование выгрузки поставил?

    Ну у меня при загрузке обьектов поидее стоит вывод сообщения ну попробуем с галочкой "комментировать"

  28. 16.04.2021 18:00:44 отредактировано NewTesla

    itdev Большой. Ты комментирование выгрузки поставил?

    тк я сам файл посмотрел он пустой, а до окаончания выгрузки, все данные в оперативке штоли содержатси?

  29. 16.04.2021 18:03:04 отредактировано itdev

    Да. Типа того

  30. ага высяснил он на одном документе сторотрится,

    даже если три выружать

  31. ща надо понять почему останавливается)

    Урааааааааааааааа!!!!!!!!!!!!!!!

или зарегистрируйтесь чтобы ответить!