Обмен между 7.7 и 8.3 с помощью КД

  1. 5 нед. назад

    Всем привет!
    кто юзал такой обмен? какие особенности есть?

    обмен нужен пользователям, чтобы выгружать и загружать данные вручную

    вот тока я не помню, а как кад запусать в 7.7 там же нету формы вроде? или есть?

  2. ‹ Ранее
  3. 3 нед. назад

    andrewks привыгрузке ты уже выгружаешь объект.
    отменить выгрузку надо перед

    Ок, спс!

  4. 25.03.2021 18:02:58 отредактировано NewTesla

    andrewks RTFM

    мануал читал я)

  5. [...]. в ПКО привыгрузке отказ не обрабатывается

    	// Обработчик "ПриВыгрузке"
    	Если ПолучитьРеквизитПКО(НомерПКО, "ПриВыгрузке") = 1 Тогда
    		
    		КодПравила = СокрЛП(ПолучитьРеквизитПКО(НомерПКО, "Код"));
    		
    		Отказ = Шаблон("[ПКО_ПриВыгрузке_" + КодПравила + "(Источник, ВходящиеДанные, ИсходящиеДанные, ИмяПКО, СтандартнаяОбработка, Приемник, УзелСсылки)]");
    
    	КонецЕсли;
    
    

    хотя в ПКГС, например, отрабатывается

    		// Обработчик "ПриВыгрузке"
    		Если ПолучитьРеквизитПКС(КоллекцияПКС, НомерПКГС, "ПриВыгрузке") = 1 Тогда
    			
    			КодПравила = СокрЛП(ПолучитьРеквизитПКО(НомерПКО, "Код")) + "_" + СокрЛП(ПолучитьРеквизитПКС(КоллекцияПКС, НомерПКГС, "Приемник")) + "_" + СокрЛП(ПолучитьРеквизитПКС(КоллекцияПКС, НомерПКГС, "ВидПриемника")) + СокрЛП(Строка(ПолучитьРеквизитПКС(КоллекцияПКС, НомерПКГС, "Код")));
    			
    			Отказ = Шаблон("[ПКГС_ПриВыгрузке_" + КодПравила + "(Источник, Приемник, ВходящиеДанные, ИсходящиеДанные, КоллекцияОбъектов, УзелКоллекцииОбъектов, УзелОбъектаКоллекции, СтандартнаяОбработка)]");
    			
    			Если Число(Отказ) = 1 Тогда
    				
    				Продолжить;
    				
    			КонецЕсли;
    	
    		КонецЕсли;
    
    
    Ответы: (32)
  6. andrewks [...]. в ПКО привыгрузке отказ не обрабатывается

    	// Обработчик "ПриВыгрузке"
    	Если ПолучитьРеквизитПКО(НомерПКО, "ПриВыгрузке") = 1 Тогда
    		
    		КодПравила = СокрЛП(ПолучитьРеквизитПКО(НомерПКО, "Код"));
    		
    		Отказ = Шаблон("[ПКО_ПриВыгрузке_" + КодПравила + "(Источник, ВходящиеДанные, ИсходящиеДанные, ИмяПКО, СтандартнаяОбработка, Приемник, УзелСсылки)]");
    
    	КонецЕсли;
    
    

    хотя в ПКГС, например, отрабатывается

    		// Обработчик "ПриВыгрузке"
    		Если ПолучитьРеквизитПКС(КоллекцияПКС, НомерПКГС, "ПриВыгрузке") = 1 Тогда
    			
    			КодПравила = СокрЛП(ПолучитьРеквизитПКО(НомерПКО, "Код")) + "_" + СокрЛП(ПолучитьРеквизитПКС(КоллекцияПКС, НомерПКГС, "Приемник")) + "_" + СокрЛП(ПолучитьРеквизитПКС(КоллекцияПКС, НомерПКГС, "ВидПриемника")) + СокрЛП(Строка(ПолучитьРеквизитПКС(КоллекцияПКС, НомерПКГС, "Код")));
    			
    			Отказ = Шаблон("[ПКГС_ПриВыгрузке_" + КодПравила + "(Источник, Приемник, ВходящиеДанные, ИсходящиеДанные, КоллекцияОбъектов, УзелКоллекцииОбъектов, УзелОбъектаКоллекции, СтандартнаяОбработка)]");
    			
    			Если Число(Отказ) = 1 Тогда
    				
    				Продолжить;
    				
    			КонецЕсли;
    	
    		КонецЕсли;
    
    

    ааа, прикольно) спс! будем знать)

  7. 26.03.2021 16:13:55 отредактировано NewTesla

    Кстати, вопрос а как передать параметры ПКО? Т.к вроде параметры только из 8 в 8 передаются)

    kkkk.jpg

    только специально прописав их?

    https://expert.chistov.pro/public/103729/

    УзелПараметра = СоздатьУзел("ЗначениеПараметра");
    УстановитьАтрибут(УзелПараметра, "Имя", "СообщениеВсемуМиру");
    ЗаписатьЭлемент(УзелПараметра, "Значение", "Здравствуй, Мир!");
    ДобавитьПодчиненный(Приемник, УзелПараметра);
    Ответы: (34)
  8. NewTesla только специально прописав их?

    да
    КД2: передача параметров из выгрузки в загрузку (в т.ч. и на ранние стадии) при обмене из 7.7 в 8.х

    Ответы: (35)
  9. andrewks да
    КД2: передача параметров из выгрузки в загрузку (в т.ч. и на ранние стадии) при обмене из 7.7 в 8.х

    вопрос тока в том, если мы хотим передать тч в тч и одно поле табличной части параметром, т. в источнике оно есть а в приемнике нету, потом, при загрузке обрабатывать надо и помещать в регистры

    это тож рисовать надо вручную?)

    Ответы: (37) (41)
  10. вопрос по параметрам.jpg

  11. NewTesla это тож рисовать надо вручную?)

    Кому щас легко? Сделай доброе дело и переведи клиента на 8-ку вместо ворошения окаменелого мамонтячего дерьма.

    Ответы: (38)
  12. ТеньД Кому щас легко? Сделай доброе дело и переведи клиента на 8-ку вместо ворошения окаменелого мамонтячего дерьма.

    ну я б с удовольствием)

    надо подкинуть тему)

    щас просто вопрос как тч перекидывать, можно ли параметр прописать в обработчке "передвыгрузкой" пкс?

  13. Будем посмотреть, как гриться)

  14. вот инфа как перебирать ща юзанем)

    https://forum.infostart.ru/forum9/topic87589/

  15. NewTesla и помещать в регистры

    в какие регистры?

    Ответы: (42)
  16. andrewks в какие регистры?

    Ну в 8.3 надо читать тч документа из 7.7 и пото записывать данные в регсведений и тп

    Ответы: (43) (44)
  17. (42) и что мешает написать соответствующие правила?

    Ответы: (44)
  18. andrewks (42) и что мешает написать соответствующие правила?

    вопрос, а как передать таблицу в параметр?

    т.е я щас делаю так, беру, назначаю ТЧ источника в ТЧ приемника, но без полей

    в модуле перед выгрузкой ПКС пишу назначение параметров

    НО! прочитать их не могу )

    идея в том, чтобы передавать саму таблицу как параметр в модуле "при выгрузке" объекта! а? круто? круто! токак как энто прописать?

    УзелПараметра = СоздатьУзел("ЗначениеПараметра");
    УстановитьАтрибут(УзелПараметра, "Имя", "СообщениеВсемуМиру");
    ЗаписатьЭлемент(УзелПараметра, "Значение", "Здравствуй, Мир!");
    ДобавитьПодчиненный(Приемник, УзелПараметра); такая ж запись не подходит

    как щас:
    выгрузка:
    ПередачаВПараметр1.jpg
    ПередачаТаблицыВПараметр2.jpg
    загрузка:
    ЗагрузкаПараметров1.jpg
    ЗагрузкаПараметров2.jpg

  19. 29.03.2021 16:31:49 отредактировано NewTesla

    Hans

    Бро, ты курс по управляемым формам проходишь, що це значит?

    Т.е есть Обьект это документ, а Отправитель это реквизит формы щоли?

    ВопросПоотправителю.jpg

    в ковертации не могу при выгрузке ему правило назначить, придется при загрузке емае)

  20. 2 нед. назад

    йоу, челики! вы где?

    кто знае как объект коллекции отправить в параметр?

  21. что то нашол [...] таблицы

    УРА!

    Ну, например в справке по "При выгрузке" ПКО вижу такое:
    
    Приемник - инициализированный xml-узел объекта приемника. Может быть дополнен призвольным xml-содержимым, например используемым при загрузке. В случае отключения СтандартнойОбработки, правила конвертации свойств (ПКС) не обрабатываются, т.е. необходимо реализовать алгоритм заполняющий узел приемника в соответствии с форматом файла обмена
    
    Пример:
    ИнформацияОПользователе = СоздатьУзел("ИнформацияОПользователе"); 
    УстановитьАтрибут(ИнформацияОПользователе, "АутентификацияОС", Источник.АутентификацияОС);
    УстановитьАтрибут(ИнформацияОПользователе, "АутентификацияСтандартная", Источник.АутентификацияСтандартная);
    УстановитьАтрибут(ИнформацияОПользователе, "ПоказыватьВСпискеВыбора", Источник.ПоказыватьВСпискеВыбора);
    УстановитьАтрибут(ИнформацияОПользователе, "ПользовательОС", Источник.ПользовательОС);
    УстановитьАтрибут(ИнформацияОПользователе, "ПолноеИмя", Источник.ПолноеИмя);
    ЧислоРолей = 1;
    Для Каждого Роль Из Источник.Роли Цикл
     УстановитьАтрибут(ИнформацияОПользователе, "Роль"+ЧислоРолей, Роль.Имя);
     Сообщить(Роль.Имя);
     ЧислоРолей = ЧислоРолей + 1;
    КонецЦикла;
    ДобавитьПодчиненный(Приемник, ИнформацияОПользователе
       fisher 
    13 - 06.03.12 - 18:40
    А в при загрузке вот такая хня:
    
    Пользователь = ПользователиИнформационнойБазы.НайтиПоИмени(СокрЛП(Объект.Код));
    Если Пользователь = Неопределено Тогда
     Пользователь = ПользователиИнформационнойБазы.СоздатьПользователя();
     Пользователь.Имя      = СокрЛП(Объект.Код);
     Пользователь.ПолноеИмя = СокрЛП(Объект.Код);
    КонецЕсли;
    Пока ФайлОбмена.Прочитать() Цикл 
     ИмяУзла = ФайлОбмена.ЛокальноеИмя; 
     ТипУзла = ФайлОбмена.ТипУзла; 
     Если ИмяУзла = "ИнформацияОПользователе" И (ТипУзла = одТипУзлаXML_НачалоЭлемента) Тогда 
      Пользователь.АутентификацияОС          = одАтрибут(ФайлОбмена, одТипБулево, "АутентификацияОС");
      Пользователь.АутентификацияСтандартная = одАтрибут(ФайлОбмена, одТипБулево, "АутентификацияСтандартная");
      Пользователь.ПоказыватьВСпискеВыбора   = одАтрибут(ФайлОбмена, одТипБулево, "ПоказыватьВСпискеВыбора");
      Пользователь.ПользовательОС            = одАтрибут(ФайлОбмена, одТипСтрока, "ПользовательОС");
      Пользователь.ПолноеИмя                 = одАтрибут(ФайлОбмена, одТипСтрока, "ПолноеИмя");
      СтрокаРоль1 = одАтрибут(ФайлОбмена, одТипСтрока, "Роль1");
      СтрокаРоль2 = одАтрибут(ФайлОбмена, одТипСтрока, "Роль2");
      СтрокаРоль3 = одАтрибут(ФайлОбмена, одТипСтрока, "Роль3");
     ИначеЕсли (ИмяУзла = "ИнформацияОПользователе") И (ТипУзла = одТипУзлаXML_КонецЭлемента) Тогда 
      Прервать; 
     КонецЕсли; 
    КонецЦикла;             
    Пользователь.ОсновнойИнтерфейс = Метаданные.Интерфейсы.Полный;
    Пользователь.Язык              = Метаданные.Языки.Русский;
    Пользователь.Роли.Очистить();
    Роль1 = Метаданные.Роли.Найти(СокрЛП(СтрокаРоль1));
    Роль2 = Метаданные.Роли.Найти(СокрЛП(СтрокаРоль1));
    Роль3 = Метаданные.Роли.Найти(СокрЛП(СтрокаРоль1));
    Если НЕ Роль1 = Неопределено Тогда
     Пользователь.Роли.Добавить(Роль1);
    КонецЕсли;
    Если НЕ Роль2 = Неопределено Тогда
     Пользователь.Роли.Добавить(Роль2);
    КонецЕсли;
    Если НЕ Роль3 = Неопределено Тогда
     Пользователь.Роли.Добавить(Роль3);
    КонецЕсли;
    Пользователь.Записать();

    ссылка

  22. #ЗагрузитьИзФайла "ввв"

    пишем, чтоб не копипастить код семерочный постоянно в обработину

    УРА!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    УРА!!!!!!!!!!!!!!!!!!
    УРА!!!!!!!!!!!

  23. КитайскийМуй Просто делаешь пустую обработку в 77, в модуле пишешь команду #ЗагрузитьИзФайла.

    Сам код модуля - сформирует КД, записываешь его в фал, который указал в команде #ЗагрузитьИзФайла.

    Только используй КД-2, а не 3.

    спс!

  24. кстати, кто юзал КД 3.0 в чем существенные различия, есть ли преимущества?

    Ответы: (51)
  25. NewTesla кстати, кто юзал КД 3.0 в чем существенные различия, есть ли преимущества?

    [...] различий. Преимуществ нет.

  26. 01.04.2021 09:25:07 отредактировано NewTesla

    Чето не врублюсь)

    почему то до этого параметры передавались потом перестали передаваться)

    в обработчике при загрузке пишет Параметры Объекта = неопределено

    хотя при вырузке я пишу

    УзелПараметра = СоздатьУзел("ЗначениеПараметра");
    УстановитьАтрибут(УзелПараметра, "Имя", "Геоданные");
    ЗаписатьЭлемент(УзелПараметра, "Значение", "789");
    ДобавитьПодчиненный(Приемник, УзелПараметра);
    

    ну, и при загрузке

    Если ПараметрыОбъекта <> Неопределено Тогда

    ПараметрыТч = ПараметрыОбъекта["ГрузовыеМестаТабличнаяЧасть"];

    Для Каждого СтрокаПараметров Из ПараметрыТч Цикл
    Сообщить(СтрокаПараметров.СообщениеВсемуМиру);
    КонецЦикла;

    Иначе
    Сообщить("Параметры объекта = Неопределено");
    КонецЕсли;

  27. 01.04.2021 09:33:42 отредактировано NewTesla
    - <Объект Нпп="1" Тип="ДокументСсылка.упЗаданиеНаПеревозкуГруза" ИмяПравила="упЗаданиеНаПеревозкуГруза">
    - <Ссылка Нпп="1">
    - <Свойство Имя="Дата" Тип="Дата">
      <Значение>2021-02-10T19:24:14</Значение> 
      </Свойство>
      </Ссылка>
    - <ЗначениеПараметра Имя="Геоданные">
      <Значение>789</Значение> 
      </ЗначениеПараметра>
    - <Свойство Имя="Организация" Тип="СправочникСсылка.Организации">
    - <Ссылка Нпп="2">
    - <Свойство Имя="Наименование" Тип="Строка">
      <Значение>Организация</Значение> 
      </Свойство>
      </Ссылка>
      </Свойство>
      </Объект>
      </ФайлОбмена>

    хотя в файле вроде есть)

  28. [...] какаято!

    ни в обработке после загрузки , ни в обработке перед загрузкой и при загрузке параметры обьекта неопределены

    я вот думаю, тк 8ка у меня а 7ка у них на серваке, мож они чего переустановили?

    насколько я помню, там есть компонента v77plus.dll, или она нина что не влияет?

  29. [...] , как полуичть гуид в 7.7 чето я подзаепси!

    Через v7plus.dll
    Код 1C v 7.x
    Инфо = СоздатьОбъект("AddIn.V7SysInfo");
    ГлобальноУникальныйИдентификатор = Инфо.СоздатьGUID();

    нашел кукуюто куету, но у меня при выгрузке ПКО Источник = Ссылка

    из ссылки надо объект сначала получить или как?

  30. Hans
    Ганисито у тебя есть стартмани?

    http://newexp.ru/public/295114/

  31. есть, чо надо?

    Ответы: (58)
  32. Hans есть, чо надо?

    надо правила качнуть)

    Ответы: (60)
  33. а то я позайопся искать как че крутить

  34. NewTesla надо правила качнуть)

    PUBID_295114-PBOUL_ACC8.zip

    Ответы: (61)
  35. Hans PUBID_295114-PBOUL_ACC8.zip

    О! Спс!

  36. !

  37. в этих правилах по дате и номеру документ ищут)))))))

    сцуко)))))))))))

  38. Крч. оказывается , в 1с 7.7 тупо нету возможности получить гуид документа!

    [...] рот)

    ну ок, придется номерами тогда орудовать

  39. крч сделал идентификатор так:

    в зависимости от периодичности можн сделать номер месяца+год+номердок

    ура!!!!!!!!!!!!!

    Строка(СокрЛП(Источник.НомерДок)+ДатаМесяц(Источник.ДатаДок) +ДатаГод(Источник.ДатаДок));

  40. Можно как-нить так:
    = Источник.НомерДок + Формат(Источник.ДатаДок, "ДДДММГГГГ");

    Ответы: (68)
  41. Это ты так с полями поиска борешься?

    Ответы: (69)
  42. itdev Можно как-нить так:
    = Источник.НомерДок + Формат(Источник.ДатаДок, "ДДДММГГГГ");

    Просто дата нельзя тк дату могут поменять же

  43. ТеньД Это ты так с полями поиска борешься?

    Угу, по идентификатору зотел для доков но чето нельзя такое, тока если паралельно формировать и запись в 7ке делать

    Ответы: (70)
  44. NewTesla Угу, по идентификатору зотел для доков но чето нельзя такое

    Уже порядочно подзабыл 7-ку, насколько помню там были функции, возвращающие ид объекта. ЗначениеВСтрокуВнутр или что-то в этом роде.

  45. По выгрузке параметров посмотрел, там оказывается в в глобальных обработчиках рекоммендуется прописвать

    т.е "при выгрузке " в самом верхнем уровне правил, а как быть если мне охота указать в модуле

    "при выгузке" ПКО?(Ща еще гляну как прога сама прописывает при обмене между 8ками Урррррррррааааааааааааааааа!!!!)

    ДанныеПоДокументам.jpg
    как хотелось бы.jpg

  46. Щегой та и в корне если прописываю то праметры объета = неопределено

    во всех процедурах при загрузке после загрузки и перед загрузкй

    мистика)

    но это дает симул посомтреть инфу по параметрам в курсе

    УРА!!!!!!!!!!!!!!!!!!!!!!!

  47. хотя до этого вроде работало

    странно, как будто есть кнопка по отключению

  48. 1Сергей

    Бро, ты вроде в семерке волокешь

    подскажи ка клучше сделать= вот мне надо чтобы в выборку не попадали документы, на основании которых был введен документ"отмена теущего" т.е бухи отменяют документ вводя на его основании другой, с началом в имени "отмена"

    вопрос = а как сделать отбор имея исходнный на руках? или это только запросом по подчиненным документам делать и перебирать их основания?

  49. itdev
    Бро , ответь на вопрос по параметрам и подчиненному документу, а то мне надо будет нанимать прогера щоб обьяснил)

    луче я тобе бабки вышлю)

  50. + цнену скажи

  51. По параметрам какой вопрос?

    Ответы: (78)
  52. itdev По параметрам какой вопрос?

    ща параметры не могу передать чегото

    пишу

    УзелПарам=СоздатьУзел("ЗначениеПараметра");
    УстановитьАтрибут(УзелПарам,"Имя","НашПараметр1другой");
    ЗаписатьЭлемент(УзелПарам,"Значение","Значение нашего параметра 1");
    ДобавитьПодчиненный(Приемник,УзелПарам);

    а при загрузке

    параметры обьекта = неопределено

    ща попробую сам узел читать

  53. привокл в том, що я раньше

    УзелПарам=СоздатьУзел("ЗначениеПараметра");
    УстановитьАтрибут(УзелПарам,"Имя","НашПараметр1другой");
    ЗаписатьЭлемент(УзелПарам,"Значение","Значение нашего параметра 1");
    ДобавитьПодчиненный(Приемник,УзелПарам);

    а при загрузке

    приемник указывал с маленькой буквы, а он принимает тока с большой)))))))

    [...]

    двигаемся дальше!

    УРА!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

    УРА!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

    УРА!!!!!!!!!!!!!!!!!!!!!!!!

  54. + параметры обьекта доступны только после загрузки, но можно сделать такую выборку

    файлобмена.выбрать()

    и тд

  55. вопрос = а запрос в 77 работают одинаков как для файловой так и для скульной версии?

    просто у меня ща вылетело с ошибкой SQl а при поторном запуске все норм

    странно

    Ответы: (84)
  56. Я думаю, если база серверная, то исполнение запроса имеет свои особенности. А вот чем отличается скульная версия 1с77, я не знаю. В восьмёрке такого нет.. может, и ничем.

  57. Блин, я семерку тыщу лет не открывал

    Ответы: (85)
  58. NewTesla просто у меня ща вылетело с ошибкой SQl а при поторном запуске все норм

    Какая хоть ошибка была? Они разные бывают. Текст ошибки надо было запомнить. Может ты просто на блокировку наступил.

    Ответы: (87)
  59. 1Сергей Блин, я семерку тыщу лет не открывал

    норм)

    itdev подсказал как запросом выбирать)

    классно!

  60. Браззы, у меня к вам еще вопросики:

    1. Как отменить загрузку документа в КД, если мы не нашли какой-то реквизит в приемнике (т.е настроили соотвесттвие и Спр.Склад =>Спр.Контрагенты) и нам надо в этом случае отменить загрузку НО! в процезурах перед загрузкой и при загрузке не могу прочитать реквизиты объекта, те они пустые , + в проц. перед загрузкой мы можем поставить оказ а в "при загрузке " не могем

    2. как лучше в 7-ке найти корневого родителя?

    т.е есть много вложенных папок в спр "Номенклатура", к родител. верхнуго уровня мы обращаемся Элем.РОдитель, а как узнать самую верхнюю папку?)

    заранее всем спасибо!)

    УРА!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

    УРА!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

    УРА!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

    Ответы: (89) (90) (102)
  61. ТеньД Какая хоть ошибка была? Они разные бывают. Текст ошибки надо было запомнить. Может ты просто на блокировку наступил.

    хз, не помню текст, но щас норм вроде, может это при первом запуске какое-то перестроение идет)

  62. Процедура КнопкаВыполнитьНажатие(Кнопка)

    РодительВерхнегоУровня = Неопределено;
    ПолучитьРодителя(Ссылка, РодительВерхнегоУровня);

    КонецПроцедуры

    Процедура ПолучитьРодителя(Элемент, РодительВерхнегоУровня)

    Если Не Элемент.Родитель.Пустая() Тогда
    ПолучитьРодителя(Элемент.Родитель, РодительВерхнегоУровня)
    Иначе
    РодительВерхнегоУровня = Элемент;
    КонецЕсли;

    КонецПроцедуры

  63. 05.04.2021 13:12:55 отредактировано КитайскийМуй

    (86) "1. Как отменить загрузку документа в КД, если мы не нашли какой-то реквизит в приемнике" - опиши это в ПКО в событии "при загрузке" или "после загрузки"

    "т.е есть много вложенных папок в спр "Номенклатура", к родител. верхнуго уровня мы обращаемся Элем.РОдитель, а как узнать самую верхнюю папку?)" - с помощью рекурсивной функции.

    Ответы: (90)
  64. КитайскийМуй (86) "1. Как отменить загрузку документа в КД, если мы не нашли какой-то реквизит в приемнике" - опиши это в ПКО в событии "при загрузке" или "после загрузки"

    "т.е есть много вложенных папок в спр "Номенклатура", к родител. верхнуго уровня мы обращаемся Элем.РОдитель, а как узнать самую верхнюю папку?)" - с помощью рекурсивной функции.

    так вот именно, если мы не нашли то в после загрузки мы не записываем обьект, да?

    Ответы: (93) (94)
  65. тк при загрузке не дает возможности ни проверить заполненность ,от отказ = истина сделать

    Ответы: (92)
  66. 05.04.2021 14:29:33 отредактировано КитайскийМуй

    (91) проверить - используй "Сообщить(..." для отладки

  67. (90) проверь уровень элемента, если он не 0 - то у него точно есть родитель

    Ответы: (94)
  68. КитайскийМуй (90) проверь уровень элемента, если он не 0 - то у него точно есть родитель

    ок отлично !

    с уровнями работает!

    тока вот щас вопросом задался = а можно ли функции в обработчиках "перед выгрузкой прописывать?"

    если да то все отличнооооо

    Ответы: (95)
  69. NewTesla а можно ли функции в обработчиках "перед выгрузкой прописывать?"

    Нельзя. Но можно прописывать алгоритмы.

    Ответы: (96)
  70. Hans Нельзя. Но можно прописывать алгоритмы.

    так вот именно, для рекурсии там функция нужна)

  71. 05.04.2021 21:07:15 отредактировано itdev

    Можно свою функцию в обработке v77exp.ert расположить. Один фиг её код растёт за счёт обработчиков

    Ответы: (99)
  72. https://forum.infostart.ru/forum9/topic58215/

  73. itdev Можно свою функцию в обработке v77exp.ert расположить. Один фиг её код растёт за счёт обработчиков

    Да тож так подумал

  74. придумал гениальную штуку

    Ðîäèòåëü = ÂûáÇàÿâêà.Òìö.Ðîäèòåëü;

    Ïîêà Ñ÷åò <> 1 Öèêë

    Ðîäèòåëü = Ðîäèòåëü.Ðîäèòåëü;
    Ñ÷åò = Ðîäèòåëü.Óðîâåíü();
    Ñîîáùèòü("Ñ÷åò = "+Ñ÷åò);
    ÊîíåöÖèêëà;

    Ñîîáùèòü("Ðîäèòåëü âåðõíåãî óðîâíÿ = "+ Ðîäèòåëü);

  75. все , я спать

  76. 05.04.2021 21:41:43 отредактировано itdev

    NewTesla Как отменить загрузку документа в КД, если мы не нашли какой-то реквизит в приемнике (т.е настроили соотвесттвие и Спр.Склад =>Спр.Контрагенты

    Может, передать значение в параметр и в обработчике перед или при загрузке проверять.

    Ответы: (103)
  77. itdev Может, передать значение в параметр и в обработчике перед или при загрузке проверять.

    я циклом попроовал вроде норм)

    Счет = ВыбЗаявка.Тмц.Уровень();
    Родитель = ВыбЗаявка.Тмц.Родитель;

    Пока Счет <> 1 Цикл
    Родитель =РОдитель.РОдитель;
    Счет = Родитель.Уровень();
    КонецЦикла;

    НужныйРодитель = Родитель;

  78. 1 нед. назад

    Вопрос к Браззам:

    есть у нас два документа одинаковых в источнике
    название : "Заявка Покупателя"

    один из документов = услуга

    в приемнике это должен быть один документ

    я сделал щас так

    1 пвд выгружае 1вый документ
    2 пвд выгружает второй и попараметрам поиска ище первый и заполняет тч "Услуги"

    ВНИМАНИЕ ВОПРОС :)

    юзер захотел одну услугу цепрять к нескольким документам

    як ето сделать? если известно, що попараметрам поиска он ищет только первый окумент вроде и берет его за основу?

  79. а, придумал!

    если хоть один найден, потом делаем запрос и делаем загрузку дкументов в модуле "после загрузки"

    ура!!!!!!!!!! ееееееееееее

  80. Вот такой вопрос еще:

    есть крч необходимость выгружать строки неограниченной длины

    но иногда строка неограниченной длины может быть пустой, поэтому я делаю проверку СокрЛП

    и проверяю на ""

    прикол в том , тчо при перед выгрузкой если ставлю проверку она работает и не выгружает

    а при выгрузке не работает наверное! и в значение параметров попадает хз что и обработка загрузки потом рушается что "конструктор не найден"

    кто сталкивался?

    СтрокаАдресКарта = СокрЛП(Источник.АдресКарта);

    Если СтрокаАдресКарта = "" Тогда
    СтрокаАдресКарта = "ПустаяСтрока";
    КонецЕсли;

    УзелПарам=СоздатьУзел("ЗначениеПараметра");
    УстановитьАтрибут(УзелПарам,"Имя","АдресКарта");
    ЗаписатьЭлемент(УзелПарам,"Значение",СтрокаАдресКарта);
    ДобавитьПодчиненный(Приемник,УзелПарам);

    Ответы: (107)
  81. 6 дн. назад

    NewTesla Вот такой вопрос еще:

    есть крч необходимость выгружать строки неограниченной длины

    но иногда строка неограниченной длины может быть пустой, поэтому я делаю проверку СокрЛП

    и проверяю на ""

    прикол в том , тчо при перед выгрузкой если ставлю проверку она работает и не выгружает

    а при выгрузке не работает наверное! и в значение параметров попадает хз что и обработка загрузки потом рушается что "конструктор не найден"

    кто сталкивался?

    СтрокаАдресКарта = СокрЛП(Источник.АдресКарта);

    Если СтрокаАдресКарта = "" Тогда
    СтрокаАдресКарта = "ПустаяСтрока";
    КонецЕсли;

    УзелПарам=СоздатьУзел("ЗначениеПараметра");
    УстановитьАтрибут(УзелПарам,"Имя","АдресКарта");
    ЗаписатьЭлемент(УзелПарам,"Значение",СтрокаАдресКарта);
    ДобавитьПодчиненный(Приемник,УзелПарам);

    Уроза рамадан начался. Теслыч ты держишь?

    Ответы: (108)
  82. Hans Уроза рамадан начался. Теслыч ты держишь?

    я держу свой член и ищу телочек)

    Ответы: (109)
  83. NewTesla я держу свой член и ищу телочек)

    Тебе надо рамадан соблюдать. Ты толстый [...]. У тебя давление уже 150 постоянно.

    Ответы: (110) (111)
  84. Hans Тебе надо рамадан соблюдать. Ты толстый [...]. У тебя давление уже 150 постоянно.

    по ТЛМС голодание раз в месяц

    а неделю голодать опасно и не продуктивно

  85. Hans Тебе надо рамадан соблюдать. Ты толстый [...]. У тебя давление уже 150 постоянно.

    я уразу в плане секса соблюдаю ща=тож норм

  86. 5 дн. назад

    вопрос по обработке выгрузке из 77, юзеры попросили сделать интерфейс попроще, я ща хочу слой добавить и при выборе. щоб параметры устанавливались, есть у кого готовый код?)

    или кто как делал?

    пользовательскийинтерфейсОбработка.jpg

  87. 14.04.2021 16:40:37 отредактировано NewTesla

    Браззы, вот еще вопрос = есть реквизит странный, который юзеры попросили заполнять программно при загрузке

    как я понял это реквизит формы " время разгрузки", а как лучше мне его заполняь тогда? ( в форме при открытии нежелательно юзать)

    hhhh.jpg

  88. т.е сама конфа у них обновляется)

    но если что как вариант можно создать отдельный реквизит и при открытии заполнять его)

    али как?

  89. Посмотри как заполняется при открытии. Если никак, то и из семёрки нечего тащить, ведь это не реквизит документа.

    Ответы: (116) (118)
  90. 14.04.2021 16:45:09 отредактировано NewTesla

    itdev Посмотри как заполняется при открытии. Если никак, то и из семёрки нечего тащить, ведь это не реквизит документа.

    не, его надо расчитывать , т.е мы берем этаж из семерки и расчитываем время разгрузки

    тока как его заполнять?

  91. 14.04.2021 16:47:24 отредактировано itdev

    Я грю, посмотри как он рассчитывается в коде восьмерки.
    Тогда будешь знать, что заполнять в конвертации

  92. itdev Посмотри как заполняется при открытии. Если никак, то и из семёрки нечего тащить, ведь это не реквизит документа.

    а на самой форме есть процедура, мы ее вызываем и она заполняет що то

    вопрос по времени разгрузки.jpg

  93. жмакаем на кнопку открывается форма для ввода времени

    в текущей форме

    &НаКлиенте
    Процедура ВвестиВремя(ПараметрыВводаВремени)
    	
    	ОткрытьФорму("ОбщаяФорма.упВводВремени", ПараметрыВводаВремени, ЭтаФорма,,ВариантОткрытияОкна.ОтдельноеОкно,,
    								  Новый ОписаниеОповещения("ОписаниеОповещенияОбратнаяОповестить",
    								  							ItobОбщегоНазначенияКлиент,
    															Новый Структура("Процедура", "УстановитьВремя")));
    	
    КонецПроцедуры
    

    * в форме ввода времени

    &НаСервере
    Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    	
    	Параметры.Свойство("ВидВремени", ВидВремени);
    	
    	ПараметрыВремя = '00010101';
    	Если Параметры.Свойство("Время", ПараметрыВремя) Тогда
    		Время = '00010101' + ПараметрыВремя;
    	КонецЕсли; 
    	
    	Если ВидВремени = "Погрузка" Тогда
    		ЭтаФорма.Заголовок = НСтр("ru='Введите время погрузки'");
    	ИначеЕсли ВидВремени = "Разгрузка" Тогда
    		ЭтаФорма.Заголовок = НСтр("ru='Введите время разгрузки'");
    	КонецЕсли;
    	
    КонецПроцедуры
    
    #КонецОбласти
    
    #Область ОбработчикиКомандФормы
    
    &НаКлиенте
    Процедура КомандаОК(Команда)
    	
    	Результат = Новый Структура;
    	Результат.Вставить("Время", 		Время);
    	Результат.Вставить("ВидВремени", 	ВидВремени);
    	
    	ЭтаФорма.Закрыть(Результат);
    	
    КонецПроцедуры
    
  94. 14.04.2021 16:51:40 отредактировано NewTesla

    почему в струкутуру не забросили, странно конечно

    пока идея такая = при открытии смотреть , если время на форме не заполнено, то брать из реквизита структуры (создать доп реквизит)

  95. 4 дн. назад

    Браззы, кто делал слои в семерке?)

    как переименовать наименование закладок?

    ВопросПоСлоям77.jpg

  96. 3 дн. назад

    а ктонить знает какой объем можно выгружать типовой выгрузкой из 77?

    а о я поставил большеой период и чето он подвис у меня

  97. 16.04.2021 17:47:36 отредактировано itdev

    Большой. Ты комментирование выгрузки поставил?

    Ответы: (124) (125)
  98. itdev Большой. Ты комментирование выгрузки поставил?

    Ну у меня при загрузке обьектов поидее стоит вывод сообщения ну попробуем с галочкой "комментировать"

  99. 16.04.2021 18:00:44 отредактировано NewTesla

    itdev Большой. Ты комментирование выгрузки поставил?

    тк я сам файл посмотрел он пустой, а до окаончания выгрузки, все данные в оперативке штоли содержатси?

  100. 16.04.2021 18:03:04 отредактировано itdev

    Да. Типа того

  101. ага высяснил он на одном документе сторотрится,

    даже если три выружать

  102. ща надо понять почему останавливается)

    Урааааааааааааааа!!!!!!!!!!!!!!!

или зарегистрируйтесь чтобы ответить!